IGH_Attributes Methods |
The IGH_Attributes type exposes the following members.
Name | Description | |
---|---|---|
AppendToAttributeTree |
Recursively append these attributes and all child attributes to the attribute list.
| |
ExpireLayout |
Expires the entire layout of the attributes. When overridden,
implementer must place a call to the base class ExpireLayout().
| |
InvalidateCanvas |
If the mouse location should cause a canvas invalidation then return true.
You only need to override this function if you draw objects that are dependant
on cursor positions outside the bounds of the attributes.
| |
IsMenuRegion |
Determines whether a point is available for context menu popups.
By default, IsMenuRegion calls IsPickRegion(PointF).
| |
IsPickRegion(PointF) |
Determines whether a point is within the pickable region for this object.
By default, any point inside the Bounds is treated as pickable.
| |
IsPickRegion(RectangleF, GH_PickBox) |
Determines whether a rectangle is a valid pick region for this object.
By default, the picking rectangle is intersected with the Bounds rectangle.
NewInstanceGuid |
Generate a new instance GUID for the owner object.
| |
NewInstanceGuid(Guid) |
Generate a new instance GUID for the owner object. Do not use this overload
unless you're > 1.95m and called David.
| |
PerformLayout |
Recompute the layout for these attributes. This function is automatically called during
Drawing operations, so you typically don't have to.
RenderToCanvas |
Render these attributes into a Canvas control.
| |
RespondToMouseDoubleClick |
This function will be called whenever the left button is double-clicked over the canvas.
RespondToMouseDown |
This function will be called whenever a mouse button is pressed over the canvas.
If you are active, you will be the only object who gets called. If you are inactive,
RespondToMouseMove |
This function will be called when the mouse moves across the canvas.
If you are active, you will be the only object who gets called. If you are inactive,
RespondToMouseUp |
This function will be called whenever a mouse button is released over the canvas.
If you are active, you will be the only object who gets called. If you are inactive,