IGH_ResponsiveObject Interface |
Namespace: Grasshopper.GUI.Canvas
The IGH_ResponsiveObject type exposes the following members.
Name | Description | |
---|---|---|
RespondToKeyDown | ||
RespondToKeyUp | ||
RespondToMouseDoubleClick |
This function will be called whenever the left button is double-clicked over the canvas.
If you are active, you will be the only object who gets called.
| |
RespondToMouseDown |
This function will be called whenever a mouse button is pressed over the canvas.
If you are active, you will be the only object who gets called. If you are inactive,
you might get called if nobody on top of you decides to become active.
| |
RespondToMouseMove |
This function will be called when the mouse moves across the canvas.
If you are active, you will be the only object who gets called. If you are inactive,
you might get called if nobody on top of you decides to become active.
| |
RespondToMouseUp |
This function will be called whenever a mouse button is released over the canvas.
If you are active, you will be the only object who gets called. If you are inactive,
you will not be called at all for MouseUp events.
|