Node3dTOptimizeTree Method |
Optimize this tree for fast searches. Do not call this method if you still plan to add items in the future.
You can no longer modify this tree once it has been optimized.
Namespace:
Grasshopper.Kernel.Geometry.SpatialTrees
Assembly:
Grasshopper (in Grasshopper.dll)
Syntax public Node3d<T> OptimizeTree()
Public Function OptimizeTree As Node3d(Of T)
Return Value
Type:
Node3dTThe new root of the optimized tree. If the root could not be optimized an instance of this node will be returned.
See Also