Grasshopper API
Grasshopper API
Grasshopper.Kernel
GH_Document Class
GH_Document Methods
ActiveObjects Method
AddObject Method
AlignObjects Method
AppendToDebugLog Method
ArrangeObject Method
ArrangeObjects Method
AssociateWithRhinoDocument Method
AutoLayoutComponents Method
AutoSave Method
AutoSaveFileName Method
BoundingBox Method
BringSelectionToTop Method
ClearIgnoreList Method
ClearReferenceTable Method
CloseAllSubsidiaries Method
ClusterInputHooks Method
ClusterInstanceCount Method
ClusterOutputHooks Method
CompareTo Method
ConstructDocumentTree Method
ContainsClusterHooks Method
ConvertFullNamesToNickNames Method
ConvertNickNamesToFullNames Method
CreateAutomaticClusterHooks Method
CreateConnectivityDiagram Method
CreateExpressionParser Method
DefineConstant Method
DeselectAll Method
DestroyAttributeCache Method
DestroyAutoSaveFiles Method
DestroyObjectTable Method
DestroyPreviewCaches Method
DestroyPreviewMeshes Method
DestroyProxySources Method
DisabledObjects Method
Dispose Method
DuplicateDocument Method
EnabledObjects Method
ExpandSelection Method
ExpirePreview Method
ExpireSolution Method
FilterActive Method
FilterDisabled Method
FilterEnabled Method
FilterInactive Method
FilterObjects Method
FilterSelected Method
FilterUnselected Method
FindAllDownstreamObjects Method
FindAttribute Method
FindAttributeByGrip Method
FindClusters Method
FindComponent Method
FindFloatingParameter Method
FindInputParameter Method
FindObject Method
FindObjects Method
FindOutputParameter Method
FindParameter Method
FindWireAt Method
ForcePreview Method
GetAllInstanceIDs Method
InactiveObjects Method
InvertSelection Method
IsEscapeKeyDown Method
IsRenderMeshPipelineViewport Method
MergeDocument Method
Modified Method
MutateAllIds Method
NewSolution Method
NonBlankFilter Method
NullFilter Method
OnContextChanged Method
OnEnabledChanged Method
OnFilePathChanged Method
OnModifiedChanged Method
OnObjectAdded Method
OnObjectDeleted Method
OnObjectsAdded Method
OnObjectsDeleted Method
OnSettingsChanged Method
OnUndoStateChanged Method
PreviewCurrentMeshParameters Method
Read Method
Redo Method
RelevantObjectAtPoint Method
RemoveObject Method
RemoveObjects Method
RemoveSelection Method
RepairProxySources Method
ReplaceProxySources Method
RequestAbortSolution Method
RunningAsCommand Method
ScheduleSolution Method
Select Method
SelectAll Method
SelectedObjects Method
SetEnabledFlags Method
SetPreviewFlags Method
SetStatusBarEventHelper Method
ShowPreviewSettings Method
SolutionProgress Method
ToggleEnabledFlags Method
TogglePreviewFlags Method
ToString Method
TranslateObjects Method
Undo Method
UnselectedObjects Method
UpdateAllSubsidiaries Method
Write Method
GH_Document
Redo Method
Perform the first redo event.
Namespace:
Grasshopper.Kernel
Assembly:
Grasshopper (in Grasshopper.dll)
Syntax
C#
VB
Copy
public
bool
Redo
()
Public
Function
Redo
As
Boolean
Return Value
Type:
Boolean
True on success, false on no redo event or invalid redo event.
See Also
Reference
GH_Document Class
Grasshopper.Kernel Namespace
Grasshopper for Rhino 8.12.24282.07000 (2024-10-08)
Copyright © 2009-2024 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com