Click or drag to resize

ObjectPropertiesPageCollection Class

Passed to Rhino.PlugIns.PlugIn.ObjectPropertiesPages to allow a plug-in to add custom ObjectPropertiesPage pages to the Rhino properties panel.
Inheritance Hierarchy
SystemObject
  Rhino.UIObjectPropertiesPageCollection

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ObjectPropertiesPageCollection

The ObjectPropertiesPageCollection type exposes the following members.

Properties
  NameDescription
Public propertyDocument
Document associated with the Rhino properties panel.
Public propertyDocumentRuntimeSerialNumber
Document associated with the Rhino properties panel.
Top
Methods
  NameDescription
Public methodAdd
Custom page to add
Top
See Also