Click or drag to resize

MouseCallback Class

Used for intercepting mouse events in the Rhino views.
Inheritance Hierarchy
SystemObject
  Rhino.UIMouseCallback

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class MouseCallback

The MouseCallback type exposes the following members.

Constructors
  NameDescription
Protected methodMouseCallback
Initializes a new instance of the MouseCallback class
Top
Properties
  NameDescription
Public propertyEnabled
Top
Methods
  NameDescription
Protected methodOnEndMouseDown
Called at the end of handling of a mouse down event in Rhino. All of the default Rhino mouse down functionality has already been executed unless a MouseCallback has set Cancel to true for the event arguments. You can tell if this is the case by inspecting the Cancel property in the event arguments parameter. Base class implementation of this function does nothing
Protected methodOnEndMouseMove
Called at the end of handling of a mouse move event in Rhino. All of the default Rhino mouse move functionality has already been executed unless a MouseCallback has set Cancel to true for the event arguments. You can tell if this is the case by inspecting the Cancel property in the event arguments parameter. Base class implementation of this function does nothing.
Protected methodOnEndMouseUp
Called at the end of handling of a mouse up event in Rhino. All of the default Rhino mouse down functionality has already been executed unless a MouseCallback has set Cancel to true for the event arguments. You can tell if this is the case by inspecting the Cancel property in the event arguments parameter. Base class implementation of this function does nothing
Protected methodOnMouseDoubleClick
Protected methodOnMouseDown
Called at the beginning of handling of a mouse down event in Rhino. If you don't want the default Rhino functionality to be run, then set Cancel to true on the passed in event arguments Base class implementation of this function does nothing
Protected methodOnMouseEnter
Protected methodOnMouseHover
Protected methodOnMouseLeave
Protected methodOnMouseMove
Called at the beginning of handling of a mouse move event in Rhino. If you don't want the default Rhino functionality to be run, then set Cancel to true on the passed in event arguments. Base class implementation of this function does nothing.
Protected methodOnMouseUp
Called at the beginning of handling of a mouse up event in Rhino. If you don't want the default Rhino functionality to be run, then set Cancel to true on the passed in event arguments Base class implementation of this function does nothing
Top
See Also