Click or drag to resize

RhinoAccoountsProgressInfo Class

This class is designed to convey the progress of an asynchronous operation through .NET's IProgressT interface. It can be used by callers of such tasks to relay the tasks' progress, as well as useful metadata information that may be of interest.
Inheritance Hierarchy
SystemObject
  Rhino.Runtime.RhinoAccountsRhinoAccoountsProgressInfo

Namespace:  Rhino.Runtime.RhinoAccounts
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class RhinoAccoountsProgressInfo

The RhinoAccoountsProgressInfo type exposes the following members.

Constructors
  NameDescription
Public methodRhinoAccoountsProgressInfo
Creates a new instance.
Top
Properties
  NameDescription
Public propertyDescription
A localized description of the state that may be shown to the user of the application.
Public propertyMetadata
Any metadata of interest that may be used by the caller of a task.
Public propertyState
The state to report.
Top
Methods
  NameDescription
Top
See Also