Click or drag to resize

IOpenIDConnectToken Interface

This class represents an OpenIDConnect token issued from an OpenID provider. The token is immutable.

Namespace:  Rhino.Runtime.RhinoAccounts
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public interface IOpenIDConnectToken

The IOpenIDConnectToken type exposes the following members.

Properties
  NameDescription
Public propertyAdminGroups
Returns all the groups the user is an admin of.
Public propertyAllGroups
Returns all the groups the user is a member of.
Public propertyAtHash
Access Token hash value. Its value is the base64url encoding of the left-most half of the hash of the octets of the ASCII representation of the access_token value, where the hash algorithm used is the hash algorithm used in the alg Header Parameter of the ID Token's JOSE Header. For instance, if the alg is RS256, hash the access_token value with SHA-256, then take the left-most 128 bits and base64url encode them. The at_hash value is a case sensitive string.
Public propertyAud
The id of the client (the audience) this token is intended for.
Public propertyAuthTime
Time when the End-User authentication occurred
Public propertyEmails
All the emails belonging to the account the token represents.
Public propertyEmailVerified
true if all the emails in the account have been verified; false otherwise.
Public propertyExp
The date the token expires.
Public propertyIat
The date the token was issued.
Public propertyIsExpired
true if the token is expired; false otherwise.
Public propertyIss
The id of the entity that issued the token.
Public propertyIsUpdated
true if the token has been updated; false otherwise.
Public propertyLocale
The local of the user this token represents. ISO 639-1 Alpha-2 [ISO639‑1] language code and an ISO 3166-1 Alpha-2 [ISO3166‑1] country code in, separated by a dash.
Public propertyMemberGroups
Returns all the groups the user is a member of, but not an admin or an owner.
Public propertyName
The name of the user this token represents.
Public propertyNonce
String value used to associate a Client session with an ID Token, and to mitigate replay attacks
Public propertyOwnerGroups
Returns all the groups the user is an owner of.
Public propertyPhone
The phone of the user this token represents.
Public propertyPicture
The url of a picture/avatar/icon of the user this token represents.
Public propertyRawToken
The raw OpenIDConnect token.
Public propertySub
The unique id for the subject this token represents.
Public propertyUpdatedAt
The last time the token was updated.
Top
See Also