Click or drag to resize

SimpleArrayMeshPointer Class

Represents a wrapper to an unmanaged array of mesh pointers.

Wrapper for a C++ ON_SimpleArray of ON_Mesh* or constant ON_Mesh*. If you are not writing C++ code then this class is not for you.

Inheritance Hierarchy
SystemObject
  Rhino.Runtime.InteropWrappersSimpleArrayMeshPointer

Namespace:  Rhino.Runtime.InteropWrappers
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SimpleArrayMeshPointer : IDisposable

The SimpleArrayMeshPointer type exposes the following members.

Constructors
  NameDescription
Public methodSimpleArrayMeshPointer
Initializes a new SimpleArrayMeshPointer instance.
Top
Properties
  NameDescription
Public propertyCount
Gets the amount of meshes in this array.
Top
Methods
  NameDescription
Public methodAdd
Adds a mesh to the list.
Public methodConstPointer
Gets the constant (immutable) pointer of this array.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the SimpleArrayMeshPointer and optionally releases the managed resources
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodNonConstPointer
Gets the non-constant pointer (for modification) of this array.
Public methodToNonConstArray
Copies the unmanaged array to a managed counterpart.
Top
See Also