Click or drag to resize

SimpleArrayClippingPlaneObjectPointer Class

ON_SimpleArray of CRhinoClippingPlaneObject*
Inheritance Hierarchy
SystemObject
  Rhino.Runtime.InteropWrappersSimpleArrayClippingPlaneObjectPointer

Namespace:  Rhino.Runtime.InteropWrappers
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SimpleArrayClippingPlaneObjectPointer : IDisposable

The SimpleArrayClippingPlaneObjectPointer type exposes the following members.

Constructors
  NameDescription
Public methodSimpleArrayClippingPlaneObjectPointer
Initializes a new SimpleArrayClippingPlaneObjectPointer instance.
Top
Properties
  NameDescription
Public propertyCount
Gets the amount of clipping planes in this array.
Top
Methods
  NameDescription
Public methodAdd
Adds a clipping plane to the list.
Public methodConstPointer
Gets the constant (immutable) pointer of this array.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the SimpleArrayClippingPlaneObjectPointer and optionally releases the managed resources
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodNonConstPointer
Gets the non-constant pointer (for modification) of this array.
Top
See Also