Click or drag to resize

IUserInterfaceSection Interface

Note: This API is now obsolete.

Implement this interface in your user control to get UserInterfaceSection event notification.

Namespace:  Rhino.Render.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[ObsoleteAttribute("Obsolete")]
public interface IUserInterfaceSection

The IUserInterfaceSection type exposes the following members.

Properties
  NameDescription
Public propertyHidden
Return true if the section should be hidden, else return false.
Top
Methods
  NameDescription
Public methodOnUserInterfaceSectionExpanding
The UserInterfaceSection object that called this interface method.
Public methodUserInterfaceDisplayData
Called by UserInterfaceSection when the selected content changes or a content field property value changes.
Top
See Also