Click or drag to resize

PostEffectChannel Class

[Missing <summary> documentation for "T:Rhino.Render.PostEffects.PostEffectChannel"]

Inheritance Hierarchy
SystemObject
  Rhino.Render.PostEffectsPostEffectChannel

Namespace:  Rhino.Render.PostEffects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class PostEffectChannel : IDisposable

The PostEffectChannel type exposes the following members.

Properties
  NameDescription
Public propertyId
Return the channel id which indicates what type of data is used in this channel.
Public propertyPixelSize
Return the pixel size in bytes for this channel.
Top
Methods
  NameDescription
Public methodClone
Return a clone of this channel.
Public methodCommit
Commit changes to the channel so that those changes can be used by subsequent post effects in the chain. Only valid for channels that were obtained by calling GetChannelForWrite(). If the channel has the same id as an existing channel, the existing channel will be replaced by the new one. If the existing channel was created by a previous post effect in the chain, it will be deleted. Changes to channels that are not commited simply get ignored. Note: This call merely sets a flag. The process is deferred until after the post effect has finished executing.
Public methodCPU
Return an interface to this channel for doing channel operations on the CPU.
Public methodDispose
Releases all resources used by the PostEffectChannel
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGPU
Return an interface to this channel for doing channel operations on the GPU.
Top
Fields
  NameDescription
Protected fieldm_cpp
Top
See Also