Click or drag to resize

RenderMeshProviderProgress Class

Expresses the progress of a custom render mesh provider.
Inheritance Hierarchy
SystemObject
  Rhino.Render.CustomRenderMeshesRenderMeshProviderProgress

Namespace:  Rhino.Render.CustomRenderMeshes
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class RenderMeshProviderProgress

The RenderMeshProviderProgress type exposes the following members.

Constructors
  NameDescription
Public methodRenderMeshProviderProgress
Initializes a new instance of the RenderMeshProviderProgress class
Top
Properties
  NameDescription
Public propertyAmount
The amount of progress towards the target
Public propertyIsComplete
true if complete, otherwise false.
Public propertyProviderId
The Id of the RenderMeshProvider that this report came from.
Public propertyTarget
Target progress
Public propertyText
Return a textural progress report
Top
Methods
  NameDescription
Top
See Also