CustomRenderMeshProviderAttribute Class |
Namespace: Rhino.Render.CustomRenderMeshes
The CustomRenderMeshProviderAttribute type exposes the following members.
Name | Description | |
---|---|---|
CustomRenderMeshProviderAttribute |
Constructor
|
Name | Description | |
---|---|---|
NonObjectIdsOnly |
If set to true, this will quickly return false for HasCustomRenderMeshes if the objectId is in the document.
| |
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.) |
Name | Description | |
---|---|---|
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.) | |
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.) | |
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.) | |
ToString | Returns a string that represents the current object. (Inherited from Object.) |