Click or drag to resize

MeshInstanceAncestryRecord Class

Information about the ancestry of a MeshInstance
Inheritance Hierarchy
SystemObject
  Rhino.Render.ChangeQueueMeshInstanceAncestryRecord

Namespace:  Rhino.Render.ChangeQueue
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class AncestryRecord : IDisposable

The MeshInstanceAncestryRecord type exposes the following members.

Constructors
  NameDescription
Public methodMeshInstanceAncestryRecord
Initializes a new instance of the MeshInstanceAncestryRecord class
Top
Properties
  NameDescription
Public propertyDefinitionId
The ModelObjectId of the InstanceDefinition
Public propertyReferenceAttributes
The object attributes from the InstanceObject
Public propertyReferenceId
The ModelObjectId of the InstanceObject
Public propertyTransform
The transform from the InstanceObject
Top
Methods
  NameDescription
Public methodDispose
Dispose
Protected methodDispose(Boolean)
Dispose. Disposes unmanaged memory.
Protected methodFinalize
Finalizer
(Overrides ObjectFinalize.)
Top
See Also