Click or drag to resize

MeshInstance Class

Representation of ChangeQueue MeshInstance
Inheritance Hierarchy
SystemObject
  Rhino.Render.ChangeQueueMeshInstance

Namespace:  Rhino.Render.ChangeQueue
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class MeshInstance

The MeshInstance type exposes the following members.

Properties
  NameDescription
Public propertyAncestry
Returns a the ancestry information for this object. Note well - the ancestry records contain complete copies of the object attributes for each level of the block hierarchy. Please do not be tempted to use the ModelObjectId of the instance objects to look them up in the document - the document may have changed since the change queue entries were added.
Public propertyCastShadows Obsolete.
Return true if mesh instance should cast shadows
Public propertyDecals Obsolete.
Read-only access to the decals for this MeshInstance if any. Null if no object attributes exist for this mesh instance.
Public propertyGroupId Obsolete.
Get identifier that specifies the grouping of these mesh instances - usually based on the object that this originally comprised.
Public propertyInstanceId
Get the instance identifier for this mesh instance.
Public propertyMaterialId
The Material CRC / RenderHash
Public propertyMeshId
Get the mesh identifier for this mesh instance.
Public propertyMeshIndex Obsolete.
Get the mesh index for this mesh instance.
Public propertyObjectAttributes
The ObjectAttributes associated with a MeshInstance
Public propertyOcsTransform Obsolete.
OCS Transform for the MeshInstance - this is the Object Coordinate System texture mapping transformation set in the texture mapping properties dialog. (identity means no OCS, potentially just simple WCS/WCS Box)
Public propertyParentId
Get the Guid of the object that is at the parent of the MeshInstance ancestry, or Guid.Empty if there is no parent.
Public propertyReceiveShadows Obsolete.
Return true if mesh instance should receive shadows
Public propertyRenderMaterial
RenderMaterial associated with mesh instance
Public propertyRootId
Get the Guid of the object that is at the root of the MeshInstance ancestry, or Guid.Empty if this has no root.
Public propertyTransform
Transform for the MeshInstance
Top
Methods
  NameDescription
Top
See Also