Click or drag to resize

LicenseLease Class

LicenseLease represents a lease returned from the Cloud Zoo
Inheritance Hierarchy
SystemObject
  Rhino.PlugInsLicenseLease

Namespace:  Rhino.PlugIns
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class LicenseLease

The LicenseLease type exposes the following members.

Constructors
  NameDescription
Public methodLicenseLease(IntPtr)
Initializes a new instance of the LicenseLease class
Public methodLicenseLease(String, String, String, String, String, String, String, String, String, DateTime, DateTime)
Initializes a new instance of the LicenseLease class
Public methodLicenseLease(String, String, String, String, String, String, String, String, String, DateTime, DateTime, DateTime)
Initializes a new instance of the LicenseLease class
Top
Properties
  NameDescription
Public propertyExpiration
The date when this lease will expire
Public propertyGroupId
ID of Rhino Accounts group that this lease came from
Public propertyGroupName
Name of Rhino Accounts group that this lease came from
Public propertyIssuedAt
The date this lease was issued
Public propertyLeaseId
The ID of this lease.
Public propertyProductEdition
Edition of product that this lease is issued to. For example, "Commercial" or "Beta"
Public propertyProductId
The ID of the product that this lease is issued to
Public propertyProductTitle
Title of product that this lease is issued to. For example, "Rhino 6"
Public propertyProductVersion
Version of product that this lease is issued to. For example, "6.0"
Public propertyRenewableUntil
The date when the license in the cloud zoo entity will expire, if any
Public propertyUserId
ID of Rhino Accounts user that was logged in when this lease was obtained
Public propertyUserName
Name of Rhino Accounts user that was logged in when this lease was obtained
Top
Methods
  NameDescription
Protected methodFinalize (Overrides ObjectFinalize.)
Top
See Also