Click or drag to resize

GpuDeviceInfo Class

Represents a GPU device providing name, vendor and memory all as strings. Currently fully implemented only on Windows.
Inheritance Hierarchy
SystemObject
  RhinoGpuDeviceInfo

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class GpuDeviceInfo

The GpuDeviceInfo type exposes the following members.

Properties
  NameDescription
Public propertyDriverDateAsString
The driver date as string formatted year-month-day
Public propertyMemory
Memory of the device in bytes
Public propertyMemoryAsString
Memory of the device as a human-readable string
Public propertyName
Name of the device
Public propertyVendor
Vendor of the device
Top
Methods
  NameDescription
Top
See Also