Click or drag to resize

RefinementSettings Class

Defines the way a mesh refinement modifier works.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.MeshRefinementsRefinementSettings

Namespace:  Rhino.Geometry.MeshRefinements
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class RefinementSettings

The RefinementSettings type exposes the following members.

Constructors
  NameDescription
Public methodRefinementSettings
Creates a default operation settings object.
Top
Properties
  NameDescription
Public propertyContinueRequest
A token to request computation termination.
Public propertyHasPull
Gets a value indicating whether this subdivision should create a result on a specific surface.
Public propertyLevel
The level of subdivision to achieve.
Public propertyNakedEdgeMode
Set this property to define how naked edges should be treated.
Top
Methods
  NameDescription
Top
See Also