Click or drag to resize

ZBufferCapture Class

Provides functionality for getting the z-buffer values from a viewport and a given display mode
Inheritance Hierarchy
SystemObject
  Rhino.DisplayZBufferCapture

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ZBufferCapture : IDisposable

The ZBufferCapture type exposes the following members.

Constructors
  NameDescription
Public methodZBufferCapture
Initializes a new instance of the ZBufferCapture class
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGrayscaleDib
Public methodHitCount
Public methodMaxZ
Public methodMinZ
Public methodSetDisplayMode
Public methodShowAnnotations
Public methodShowCurves
Public methodShowIsocurves
Public methodShowLights
Public methodShowMeshWires
Public methodShowPoints
Public methodShowText
Public methodWorldPointAt
Public methodZValueAt
Top
See Also