Click or drag to resize

Text3d Class

3D aligned text with font settings.
Inheritance Hierarchy
SystemObject
  Rhino.DisplayText3d

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class Text3d : IDisposable

The Text3d type exposes the following members.

Constructors
  NameDescription
Public methodText3d(String)
Constructs a new instance of Text3d.
Public methodText3d(String, Plane, Double)
Constructs a new instance of Text3d.
Top
Properties
  NameDescription
Public propertyBold
Gets or sets whether this Text3d object will be drawn in Bold.
Public propertyBoundingBox
Gets the bounding box for this Text3d object.
Public propertyFontFace
Gets or sets the FontFace name.
Public propertyHeight
Gets or sets the height (in units) of this Text3d object. The height should be a positive number larger than zero.
Public propertyHorizontalAlignment
Horizontal alignment that this Text3d is drawn with
Public propertyItalic
Gets or sets whether this Text3d object will be drawn in Italics.
Public propertyText
Gets or sets the text string for this Text3d object.
Public propertyTextPlane
Gets or sets the 3D aligned plane for this Text3d object.
Public propertyVerticalAlignment
Vertical alignment that this Text3d is drawn with
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Top
See Also