Click or drag to resize

DisplayConduit Class

[Missing <summary> documentation for "T:Rhino.Display.DisplayConduit"]

Inheritance Hierarchy
SystemObject
  Rhino.DisplayDisplayConduit

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class DisplayConduit

The DisplayConduit type exposes the following members.

Constructors
  NameDescription
Protected methodDisplayConduit
Initializes a new instance of the DisplayConduit class
Top
Properties
  NameDescription
Public propertyEnabled
Public propertyGeometryFilter
The geometry filter will ensure that your conduit's per-object functions will only be called for objects that are of certain geometry type
Public propertySpaceFilter
If you want this conduit to only work in a specific space (model or page), then set this filter to that specific space. The default is None meaning no filter is applied
Top
Methods
  NameDescription
Protected methodCode exampleCalculateBoundingBox
Library developers should override this function to increase the bounding box of scene so it includes the geometry that you plan to draw in the "Draw" virtual functions.

The default implementation does nothing.

Protected methodCalculateBoundingBoxZoomExtents
If you want to participate in the Zoom Extents command with your display conduit, then you will need to override ZoomExtentsBoundingBox. Typically you could just call your CalculateBoundingBox override, but you may also want to spend a little more time here and compute a tighter bounding box for your conduit geometry if that is needed.

The default implementation does nothing.

Protected methodDrawForeground
Called after all non-highlighted objects have been drawn and PostDrawObjects has been called. Depth writing and testing are turned OFF. If you want to draw with depth writing/testing, see PostDrawObjects.

The default implementation does nothing.

Protected methodDrawOverlay
If Rhino is in a feedback mode, the draw overlay call allows for temporary geometry to be drawn on top of everything in the scene. This is similar to the dynamic draw routine that occurs with custom get point.

The default implementation does nothing.

Public methodGetSelectionFilter
The selection filter will make per-object conduit functions only be called for selected objects (when the filter is turned on)
Protected methodObjectCulling

The default implementation does nothing.

Protected methodOnEnable
Called when the enabled state changes for this class instance
Protected methodPostDrawObjects
Called after all non-highlighted objects have been drawn. Depth writing and testing are still turned on. If you want to draw without depth writing/testing, see DrawForeground.

The default implementation does nothing.

Protected methodPreDrawObject
Called before every object in the scene is drawn.
Protected methodCode examplePreDrawObjects
Called before objects are been drawn. Depth writing and testing are on.

The default implementation does nothing.

Public methodSetObjectIdFilter(Guid)
Set an object Id that this conduit's per-object functions will only be called for
Public methodSetObjectIdFilter(IEnumerableGuid)
Set object Ids that this conduit's per-object functions will only be called for
Public methodSetSelectionFilter
The selection filter will make per-object conduit functions only be called for selected objects (when the filter is turned on)
Top
See Also