Click or drag to resize

ColorGradient Class

[Missing <summary> documentation for "T:Rhino.Display.ColorGradient"]

Inheritance Hierarchy
SystemObject
  Rhino.DisplayColorGradient

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ColorGradient

The ColorGradient type exposes the following members.

Constructors
  NameDescription
Public methodColorGradient
Initializes a new instance of the ColorGradient class
Top
Properties
  NameDescription
Public propertyEndPoint
End point of gradient
Public propertyGradientType
Gradient fill type associated with this hatch
Public propertyRepeat
Repeat factor for gradient. Factors greater than 1 define a reflected repeat factor while values less than -1 define a wrapped repeat factor.
Public propertyStartPoint
Start point of gradient
Top
Methods
  NameDescription
Public methodDuplicate
Create a duplicate of this color gradient.
Public methodGetColorStops
Get sorted list of colors / positions that a gradient is defined over
Public methodSetColorStops
Set color stops for the gradient
Top
See Also