Click or drag to resize

RhinoList Class

Inheritance Hierarchy
SystemObject
  Rhino.CollectionsRhinoList

Namespace:  Rhino.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class RhinoList

The RhinoList type exposes the following members.

Methods
  NameDescription
Public methodStatic memberPoint2dKNeighbors
Finds a certain amour of points in a list of single-precision 2D points that are the k-closest to a test point. This method searches needlePoints by computing all distances from each point cloud point and keeping a "short list".
Public methodStatic memberPoint2fKNeighbors
Finds a certain amour of points in a list of single-precision 2D points that are the k-closest to a test point. This method searches needlePoints by computing all distances from each point cloud point and keeping a "short list".
Public methodStatic memberPoint3dKNeighbors
Finds a certain amour of points in a list of 3D points that are the k-closest to a test point. This method searches needlePoints by computing all distances from each point cloud point and keeping a "short list". See RTree KNeighbors for alternatives.
Public methodStatic memberPoint3fKNeighbors
Finds a certain amour of points in a list of single-precision 3D points that are the k-closest to a test point. This method searches needlePoints by computing all distances from each point cloud point and keeping a "short list".
Public methodStatic memberPointCloudKNeighbors
Finds a certain amount of points in a list of 3D points that are the k-closest to a test point. This method searches needlePoints by computing all distances from each point cloud point and keeping a short list.
Top
See Also