Click or drag to resize

StackedDialogPage Properties

The StackedDialogPage type exposes the following members.

Properties
  NameDescription
Public propertyChildren
List of child (sub) pages of this page
Public propertyEnglishPageTitle
English string used when scripting this page and a user prefixes a command option with "_"
Public propertyHandle
When running on Windows return the window handle for the parent of this page otherwise; return IntPtr.Zero.
Public propertyHasChildren
Will be true if this page contains sub pages.
Public propertyLocalPageTitle
Localized page title that will appear on a tab or other page navigation control. This is also uses as a command line option when scripting this page.
Public propertyModified
Check to see if the page has been marked as modified or not. Marking the page as modified will cause the Apply button to get enabled if this is currently the visible page and the page includes the Apply button.
Public propertyNavigationTextColor
Currently only used by Windows Rhino. If this is set to true then the tree control item text be drawn using this color. Set the color to System.Drawing.Color.Empty to use the default color.
Public propertyNavigationTextIsBold
Currently only used by Windows Rhino. If this is set to true then the tree control item text will be bold.
Public propertyPageControl
Return the control that represents this page. Rhino Windows supports classes that implement the IWin32Windows interface or are derived from some form of System.Windows.FrameworkElement or Eto.Forms.Control. Mac Rhino supports controls that are derived from NSview or Eto.Forms.Control.
Public propertyPageImage
Optionally override to provide a image to display in the Mac Rhino UI
Public propertyShowApplyButton
Called when this page is activated
Public propertyShowDefaultsButton
Called when this page is activated.
Top
See Also