Click or drag to resize

OpenFileDialog Properties

The OpenFileDialog type exposes the following members.

Properties
  NameDescription
Public propertyDefaultExt
The default file name extension. The returned string does not include the period.
Public propertyCode exampleFileName
Gets or sets a string containing the file name selected in the file dialog box.
Public propertyFileNames
Gets the names of all of the selected files in the dialog box
Public propertyCode exampleFilter
Gets or sets the current file name filter string, which determines the choices that appear in the "Save as file type" or "Files of type" box in the dialog box. See System.Windows.Forms.FileDialog for details.
Public propertyInitialDirectory
Gets or sets the initial directory displayed by the file dialog box.
Public propertyMultiSelect
Gets or sets a value indicating whether the dialog box allows multiple files to be selected
Public propertyTitle
Gets or sets the file dialog box title.
Top
See Also