Click or drag to resize

GumballAppearanceSettings Properties

The GumballAppearanceSettings type exposes the following members.

Properties
  NameDescription
Public propertyArcThickness
in pixels.
Public propertyArrowHeadLength
in pixels.
Public propertyArrowHeadWidth
in pixels.
Public propertyAxisThickness
in pixels.
Public propertyColorMenuButton
Public propertyColorX
Default is Red.
Public propertyColorY
Default is Green.
Public propertyColorZ
Default is Blue.
Public propertyFreeTranslate
When FreeTranslate is 1, the center translation control can be dragged in any direction and moves the object the gumball controls. When FreeTranslate is 2, the center translation control can be dragged in any direction and moves the object the gumball itself. The default value is 2.
Public propertyMenuDistance
Distance of menu ball from center.
Public propertyMenuEnabled
When MenuEnabled is true, the menu "button" is drawn on the gumball. The default setting is true.
Public propertyMenuSize
Radius of menu circle.
Public propertyPlanarTranslationGripCorner
in pixels.
Public propertyPlanarTranslationGripSize
in pixels.
Public propertyRadius
in pixels.
Public propertyRelocateEnabled
When RelocateEnabled is true, the user can reposition the gumball by tapping the control key while dragging. Once the repostion drag is terminated by releasing the/ mouse button, ordinary editing resumes. The default setting is true.
Public propertyRotateXEnabled
When RotateX is true, the X rotation control is available. The default setting is true.
Public propertyRotateYEnabled
When RotateY is true, the Y rotation control is available. The default setting is true.
Public propertyRotateZEnabled
When RotateZ is true, the Z rotation control is available. The default setting is true.
Public propertyScaleGripSize
in pixels.
Public propertyScaleXEnabled
When ScaleXEnabled is true, the X scale control is available. The default setting is true.
Public propertyScaleYEnabled
When ScaleYEnabled is true, the Y scale control is available. The default setting is true.
Public propertyScaleZEnabled
When ScaleZEnabled is true, the Z scale control is available. The default setting is true.
Public propertyTranslateXEnabled
TranslateXEnabled is true, the X axis translation control is available. The default setting is true.
Public propertyTranslateXYEnabled
When TranslateXY is true, the XY plane translation control is available in appropriate views. The default setting is true.
Public propertyTranslateYEnabled
TranslateYEnabled is true, the Y axis translation control is available. The default setting is true.
Public propertyTranslateYZEnabled
When TranslateYZ is true, the YZ plane translation control is available in appropriate views. The default setting is true.
Public propertyTranslateZEnabled
TranslateZEnabled is true, the Z axis translation control is available. The default setting is true.
Public propertyTranslateZXEnabled
When TranslateZX is true, the ZX plane translation control is available in appropriate views. The default setting is true.
Top
See Also