Click or drag to resize

RhinoDoc Properties

The RhinoDoc type exposes the following members.

Properties
  NameDescription
Public propertyActiveCommandId
Get the ID of the active command.
Public propertyStatic memberActiveDoc
WARNING!! Do not use the ActiveDoc if you don't have to. Under Mac Rhino the ActiveDoc can change while a command is running. Use the doc that is passed to you in your RunCommand function or continue to use the same doc after the first call to ActiveDoc.
Public propertyActiveSpace
Get the space associated with the active view for this document
Public propertyAnimationProperties
Public propertyBitmaps
bitmaps used in textures, backgrounds, wallpapers, ...
Public propertyCurrentEnvironment Obsolete.
Access to the current environment for various uses
Public propertyCurrentUndoRecordSerialNumber
>0: undo recording is active and being saved on the undo record with the specified serial number. 0: undo recording is not active. (Disabled or nothing is being recorded.)
Public propertyCustomRenderSizes
Public propertyDateCreated
Public propertyDateLastEdited
Returns the date the document was created in Coordinated Universal Time (UTC). Use DateTime.ToLocalTime to convert to local time.
Public propertyCode exampleDimStyles
Public propertyDistanceDisplayPrecision
Public propertyEarthAnchorPoint
Public propertyFonts Obsolete.
Public propertyGroundPlane Obsolete.
Gets the ground plane of this document.
Public propertyCode exampleGroups
Public propertyCode exampleHatchPatterns
Public propertyInGetPoint
Returns true if currently in a GetPoint.Get().
Public propertyCode exampleInstanceDefinitions
Public propertyIsAvailable
Public propertyIsClosing
Public propertyIsCommandRunning
Returns true if Rhino is currently running a command.
Public propertyIsCreating
Public propertyIsHeadless
Public propertyIsInitializing
Public propertyIsLocked
Check to see if the file associated with this document is locked. If it is locked then this is the only document that will be able to write the file. Other instances of Rhino will fail to write this document.
Public propertyIsOpening
Public propertyIsReadOnly
Current read-only mode for this document. true if the document can be viewed but NOT saved. false if document can be viewed and saved.
Public propertyIsSendingMail
true if Rhino is in the process of sending this document as an email attachment.
Public propertyLayers
Layers in the document.
Public propertyLayoutSpaceAnnotationScalingEnabled
If LayoutSpaceAnnotationScaling is on, sizes in dimstyles are multiplied by dimscale when the annotation is displayed in a detail viewport not in a detail
Public propertyLights
Public propertyLinetypes
Linetypes in the document.
Public propertyManifest
Public propertyMaterials
Materials in the document.
Public propertyMeshingParameterStyle
Type of MeshingParameters currently used by the document to mesh objects
Public propertyModelAbsoluteTolerance
Model space absolute tolerance.
Public propertyModelAngleToleranceDegrees
Model space angle tolerance.
Public propertyModelAngleToleranceRadians
Model space angle tolerance.
Public propertyModelBasepoint
The base point in the model that is used when inserting the model into another as a block definition. By default the base point in any model is 0,0,0.
Public propertyCode exampleModelDistanceDisplayPrecision
Public propertyModelRelativeTolerance
Model space relative tolerance.
Public propertyModelSpaceAnnotationScalingEnabled
If ModelSpaceAnnotationScaling is on, sizes in dimstyles are multiplied by dimscale when the annotation is displayed in a model space viewport not in a detail
Public propertyModelSpaceHatchScale
The scale factor for hatches in model space when Hatch Scaling is enabled
Public propertyModelSpaceHatchScalingEnabled
True if hatch scaling is enabled, false if not.
Public propertyModelSpaceTextScale
The scale factor for text in model space when Annotation Scaling is enabled
Public propertyModelUnitSystem
Public propertyModified
Returns or sets the document's modified flag.
Public propertyName
Returns the name of the currently loaded Rhino document (3DM file).
Public propertyNamedConstructionPlanes
Collection of named construction planes.
Public propertyNamedLayerStates
Collection of named layer states.
Public propertyNamedPositions
Collection of named positions.
Public propertyCode exampleNamedViews
Collection of named views.
Public propertyNextUndoRecordSerialNumber
The serial number that will be assigned to the next undo record that is constructed.
Public propertyNotes
Returns or sets the document's notes.
Public propertyNotesLocked
Public propertyObjects
Public propertyPageAbsoluteTolerance
Page space absolute tolerance.
Public propertyPageAngleToleranceDegrees
Page space angle tolerance.
Public propertyPageAngleToleranceRadians
Page space angle tolerance.
Public propertyPageDistanceDisplayPrecision
Public propertyPageRelativeTolerance
Page space relative tolerance.
Public propertyCode examplePageUnitSystem
Public propertyPath
Returns the path of the currently loaded Rhino document (3DM file).
Public propertyPostEffects Obsolete.
Access to the post effects
Public propertyRedoActive
Returns true if Redo is currently active.
Public propertyRenderEnvironments
Public propertyRenderMaterials
Public propertyRenderSettings
Public propertyRenderTextures
Public propertyRuntimeData
Collection of document runtime data. This is a good place to put non-serializable, per document data, such as panel view models. Note well: This data will be dispose with the document and does not get serialized.
Public propertyRuntimeSerialNumber
Unique serialNumber for the document while the application is running. This is not a persistent value.
Public propertySnapshots
Collection of snapshots.
Public propertyStrings
Collection of document user data strings in this document
Public propertySubDAppearance
Returns or sets the appearance of all SubD objects in the document.
Public propertyTemplateFileUsed
name of the template file used to create this document. This is a runtime value only present if the document was newly created.
Public propertyUndoActive
Returns true if Undo is currently active.
Public propertyUndoRecordingEnabled
Public propertyUndoRecordingIsActive
true if undo recording is actually happening now.
Public propertyViews
Public propertyWorksession
Provides access to the document's worksession.
Top
See Also