Click or drag to resize

Sun Properties

The Sun type exposes the following members.

Properties
  NameDescription
Public propertyAccuracy
Accuracy.
Public propertyAltitude
The sun's altitude above the horizon in degrees in the range -90 to +90. Setting this value will also set the sun to manual control mode.
Public propertyAzimuth
The sun's azimuth in degrees. The value increases Eastwards with North as zero. Setting this value will also set the sun to manual control mode. Note: This value is not affected by the direction of north.
Public propertyDaylightSaving Obsolete.
Public propertyDaylightSavingMinutes
Daylight saving time in minutes
Public propertyDaylightSavingOn
Daylight saving time 'on' state
Public propertyEnabled
Turn the sun on/off in this document.
Public propertyHash
Get a hash of the sun state.
Public propertyIntensity
Sun intensity.
Public propertyLatitude
The observer's latitude.
Public propertyLight
Get a Light which represents the sun. If manual control is in effect, no sun calculation is performed; the function uses the last known values of azimuth and altitude. If manual control is not in effect, the observer's position, date, time, time zone and daylight saving values are used to calculate the position of the sun.
Public propertyLongitude
The observer's longitude.
Public propertyManualControl Obsolete.
Public propertyManualControlOn
Manual control 'on' state. When true, allows the user to set the sun azimuth and altitude directly. When false, the values are computed.
Public propertyNorth
Angle in degrees on world X-Y plane that should be considered north in the model. The angle is measured starting at the x-axis and increases anti-clockwise. The y-axis corresponds to a 'north' angle of 90 degrees.
Public propertySkylightOn Obsolete.
Turn skylight on or off.
Public propertyTimeZone
The observer's time zone measured in hours relative to UTC.
Public propertyVector
Top
See Also