RenderEnvironment Properties |
The RenderEnvironment type exposes the following members.
Name | Description | |
---|---|---|
DocumentAssoc |
If this render content is associated with a document in any way, the document will be returned. This includes copies of
DocumentOwner |
If this render content is owned by a document, the document will be returned.
This is the same as getting the document the render content is attached to.
Fields |
Rhino.Render.Fields FieldDictionary which provides access to setting
Filename |
If the content is file based, this function can be overridden to deal with setting/getting the
FilesToEmbed |
A string array of full paths to files used by the content that may be
embedded in .3dm files and library files (.rmtl, .renv, .rtex). The
default implementation returns an empty string list. Override this to
return the file name or file names used by your content. This is
typically used by textures that reference files containing the texture
Hidden |
Gets or sets the render content's 'hidden' state. This feature only works for top-level render contents
because it hides the entire hierarchy. It is normally used for 'implementation detail' render contents.
For expert use only. Hidden render contents are never shown in the UI, with the exception of the Object
(or Layer) Material Properties UI which always shows whatever is assigned to the object (or layer).
In the Object (or Layer) Material Properties UI, if the user drops down the list, hidden render contents
are not listed. Hidden render contents, being part of the document content list, will be listed by any
scripts or other code that iterates over the document render content list. It is recommended that you set
IsHiddenByAutoDelete |
Contents can be created as 'auto-delete' by certain commands such as 'Picture'.
These contents are automatically hidden from the user when the associated Rhino object
IsLocked |
Set this property to true prior to adding content to the document to
lock the content browser editing UI methods. Setting this to true will
keep the browser from allowing things like deleting, renaming or
changing content. This is useful for custom child content that you
want to be editable but persistent. Setting this after adding content
RenderHash |
Render hash for the content hierarchy. It iterates over children and includes a caching
mechanism which means the hash value can be retrieved quickly if it hasn't changed.
The cache is invalidated when Changed() is called.