Click or drag to resize

RenderContent Properties

The RenderContent type exposes the following members.

Properties
  NameDescription
Public propertyCanBeEdited
Determines if the content can be edited.
Public propertyCategory
Category for this content.
Public propertyChildSlotDisplayName
Returns the localized display name of the child slot name
Public propertyChildSlotName
Public propertyCppPointer
Public propertyDisplayName
Display name for this content.
Public propertyDocument Obsolete.
Obsolete. Do not use. You should use DocumentOwner instead.
Public propertyDocumentAssoc
If this render content is associated with a document in any way, the document will be returned. This includes copies of render contents that were attached to a document when the copy was made. Otherwise returns null.
Public propertyDocumentOwner
If this render content is owned by a document, the document will be returned. This is the same as getting the document the render content is attached to. Otherwise returns null.
Public propertyDocumentRegistered Obsolete.
Obsolete. Do not use. You should use DocumentOwner instead.
Public propertyFields
Rhino.Render.Fields FieldDictionary which provides access to setting and retrieving field values.
Public propertyFilename
If the content is file based, this function can be overridden to deal with setting/getting the filename. Corresponds to IRhRdkFileBasedContent in the C++ SDK
Public propertyFilesToEmbed
A string array of full paths to files used by the content that may be embedded in .3dm files and library files (.rmtl, .renv, .rtex). The default implementation returns an empty string list. Override this to return the file name or file names used by your content. This is typically used by textures that reference files containing the texture imagery.
Public propertyFirstChild
Return First child of this content or null if none.
Public propertyGroupId
Group ID of the content
Public propertyHidden
Gets or sets the render content's 'hidden' state. This feature only works for top-level render contents because it hides the entire hierarchy. It is normally used for 'implementation detail' render contents. For expert use only. Hidden render contents are never shown in the UI, with the exception of the Object (or Layer) Material Properties UI which always shows whatever is assigned to the object (or layer). In the Object (or Layer) Material Properties UI, if the user drops down the list, hidden render contents are not listed. Hidden render contents, being part of the document content list, will be listed by any scripts or other code that iterates over the document render content list. It is recommended that you set IsHidden once when you create your render content and leave it on to prevent flicker or slow performance.
Public propertyId
Instance identifier for this content.
Public propertyIsDefaultInstance
Checks if render content is default instance.
Public propertyIsHiddenByAutoDelete
Contents can be created as 'auto-delete' by certain commands such as 'Picture'. These contents are automatically hidden from the user when the associated Rhino object is deleted. They are later deleted when the document is saved.
Public propertyIsLocked
Set this property to true prior to adding content to the document to lock the content browser editing UI methods. Setting this to true will keep the browser from allowing things like deleting, renaming or changing content. This is useful for custom child content that you want to be editable but persistent. Setting this after adding content to the document will cause an exception to be thrown.
Public propertyName
Instance 'raw' name for this content.
Public propertyNextSibling
Return First sibling of this content or null if none.
Public propertyNotes
Notes for this content.
Public propertyParent
Returns the top content in this parent/child chain.
Public propertyProxyType
Gets the proxy type of the render content
Public propertyRenderHash
Render hash for the content hierarchy. It iterates over children and includes a caching mechanism which means the hash value can be retrieved quickly if it hasn't changed. The cache is invalidated when Changed() is called. You can override the CalculateRenderHash(UInt64) method to provide a custom hash value.
Public propertyStyles
Public propertyTags
Tags for this content.
Public propertyTopLevel
Returns true if this content has no parent, false if it is the child of another content.
Public propertyTopLevelParent
Returns the top content in this parent/child chain.
Public propertyTypeDescription
Description for your content type. i.e., "Procedural checker pattern"
Public propertyTypeId
Type identifier for this content
Public propertyTypeName
Name for your content type. i.e., "My .net Texture"
Public propertyXml
Top
See Also