Click or drag to resize

Decal Properties

The Decal type exposes the following members.

Properties
  NameDescription
Public propertyCRC
The decal CRC identifies a decal by its state. Multiple decals which would be exactly the same would have the same CRC and are culled from the system. If you store this value with the intention of using it to find the decal again later, you must update your stored value whenever the decal state changes. You can detect when a decal changes by watching for the OnUserDataTransformed event.
Public propertyDecalMapping Obsolete.
Gets the decal's mapping.
Public propertyDecalProjection Obsolete.
Gets the decal's projection. Used only when mapping is planar.
Public propertyEndLatitude
Gets the end angle of the decal's arc of latitude or 'horizontal sweep'. This is actually a LONGITUDINAL angle. Only used when mapping is cylindrical or spherical. This is deprecated in favor of HorzSweep().
Public propertyEndLongitude
Gets the end angle of the decal's arc of longitude or 'vertical sweep'. This is actually a LATITUDINAL angle. Only used when mapping is spherical. This is deprecated in favor of VertSweep().
Public propertyHeight
Gets the height of the decal. Only used when mapping is cylindrical.
Public propertyMapping
Gets the decal's mapping.
Public propertyMapToInside
Used only when mapping is cylindrical or spherical.
Public propertyOrigin
Gets the origin of the decal in world space.
Public propertyProjection
Gets the decal's projection. Used only when mapping is planar.
Public propertyRadius
Gets the radius of the decal. Only used when mapping is cylindrical or spherical.
Public propertyStartLatitude
Gets the start angle of the decal's arc of latitude or 'horizontal sweep'. This is actually a LONGITUDINAL angle. Only used when mapping is cylindrical or spherical. This is deprecated in favor of HorzSweep().
Public propertyStartLongitude
Gets the start angle of the decal's arc of longitude or 'vertical sweep'. This is actually a LATITUDINAL angle. Only used when mapping is spherical. This is deprecated in favor of VertSweep().
Public propertyTextureInstanceId
Gets the texture ID for this decal.
Public propertyTransparency
Gets the decal's transparency in the range 0 to 1.
Public propertyVectorAcross
Gets the vector across. For cylindrical and spherical mapping, the vector is unitized.
Public propertyVectorUp
For cylindrical and spherical mapping, the vector is unitized.
Top
See Also