Click or drag to resize

PlugIn Properties

The PlugIn type exposes the following members.

Properties
  NameDescription
Public propertyAddToHelpMenu
Called by Rhino to determine if the plug-in name should be added to the Rhino Help/Plug-ins menu.
Public propertyStatic memberAskOnLoadProtection
If true, Rhino will display a warning dialog when load-protected plug-ins are attempting to load. If false, load-protected plug-ins will silently not load.
Public propertyAssembly
Source assembly for this plug-in.
Public propertyDescription
Returns the description of the plug-in, as found in the plug-in's assembly attributes.
Public propertyId
Returns the Guid, or unique Id, of the plug-in.
Public propertyStatic memberInstalledPlugInCount
Returns the number of installed Rhino plug-ins.
Public propertyLicenseId
Public propertyLoadAtStartup Obsolete.
Public propertyLoadTime
Plug-ins are typically loaded on demand when they are first needed. You can change this behavior to load the plug-in at during different stages in time by overriding this property.
Protected propertyLocalPlugInName
Optionally override this to provide a localized plug-in name
Public propertyName
Returns the name of the plug-in, as found in the plug-in's assembly attributes.
Public propertySettings
Persistent plug-in settings.
Public propertySettingsDirectory
Get the plug-in's settings directory. This is the directory where the plug-in's persistent settings files are saved. This directory will be located in the user's profile folder. Note, this does not verify the directory exists.
Public propertySettingsDirectoryAllUsers
Get the plug-in's "all users" settings directory. This directory will be located in the system's program data folder. Note, this does not verify the directory exists.
Public propertyVersion
Returns the version of the plug-in, as found in the plug-in's assembly attributes.
Public propertyWindowPositionSettings
Top
See Also