Click or drag to resize

LicenseStatus Properties

The LicenseStatus type exposes the following members.

Properties
  NameDescription
Public propertyBuildType
The build contentType of the product, where: 100 = A release build, either commercial, education, NFR, etc. 200 = A evaluation build 300 = A beta build, such as a WIP.
Public propertyCheckOutExpirationDate
The date and time the checked out license will expire. Note, this is only set if m_license_type = Standalone or CloudZoo and if "limited license checkout" was enabled on the Zoo server in the case of Standalone. Note, date and time is in local time coordinates.
Public propertyCloudZooLeaseExpiration
Returns the expiration date of the lease this instance represents.
Public propertyCloudZooLeaseIsValid
Returns true if the Cloud Zoo Lease represented by this instance is actively being managed by the Cloud Zoo Manager; else returns false.
Public propertyExpirationDate
The date and time the license will expire. This value can be null if: 1.) The license contentType is "Standalone" and the license does not expire. 2.) The license contentType is "Network". 3.) The license contentType is "NetworkCheckedOut" and the checkout does not expire Note, date and time is in local time coordinates.
Public propertyLicenseTitle
The title of the license. (e.g. "Rhinoceros 6.0 Commercial")
Public propertyLicenseType
The license contentType. (e.g. Standalone, Network, etc.)
Public propertyPluginId
The ID of the plug-in that owns this license information
Public propertyProductIcon
The product's icon. Note, this can be null.
Public propertyProductId
The id of the product or plug in.
Public propertyRegisteredOrganization
The registered organization of the product (e.g. "Robert McNeel and Associates")
Public propertyRegisteredOwner
The registered owner of the product. (e.g. "Dale Fugier")
Public propertySerialNumber
The "for display only" product license or serial number.
Top
See Also