Click or drag to resize

RhinoViewport Properties

The RhinoViewport type exposes the following members.

Properties
  NameDescription
Public propertyBounds
Gets the size and location of the viewport, in pixels, relative to the parent view.
Public propertyCamera35mmLensLength
Public propertyCameraDirection
Public propertyCameraLocation
Public propertyCameraTarget
Viewport target point.
Public propertyCode exampleCameraUp
Public propertyCameraX
Gets the "unit to the right" vector.
Public propertyCameraY
Gets the "unit up" vector.
Public propertyCameraZ
Gets the unit vector in CameraDirection.
Public propertyChangeCounter
The value of change counter is incremented every time the view projection or construction plane changes. The user can the mouse and nestable view manipulation commands to change a view at any time. The value of change counter can be used to detect these changes in code that is sensitive to the view projection.
Public propertyConstructionAxesVisible
Public propertyConstructionGridVisible
Public propertyDisplayMode
Public propertyFrustumAspect
Gets the width/height ratio of the frustum.
Public propertyId
Unique id for this viewport.
Public propertyIsParallelProjection
Public propertyIsPerspectiveProjection
Public propertyIsPlanView
true if construction plane z axis is parallel to camera direction.
Public propertyIsTwoPointPerspectiveProjection
Public propertyIsValidCamera
Public propertyIsValidFrustum
Public propertyLockedProjection
If true, the the camera location, camera direction, and lens angle should not be changed.
Public propertyCode exampleName
Name associated with this viewport.
Public propertyParentView
Gets the parent view, if there is one Every RhinoView has an associated RhinoViewport that does all the 3d display work. Those associated viewports return the RhinoView as their parent view. However, RhinoViewports are used in other image creating contexts that do not have a parent RhinoView. If you call ParentView, you MUST check for NULL return values.
Public propertyScreenPortAspect
screen port's width/height.
Public propertyCode exampleSize
Get or set the height and width of the viewport (in pixels)
Public propertyUserStringCount
Public propertyViewportType
Public propertyWallpaperFilename
Public propertyWallpaperGrayscale
Public propertyWallpaperVisible
Public propertyWorldAxesVisible
Top
See Also