Click or drag to resize

ViewSettings Properties

The ViewSettings type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberAlwaysPanParallelViews
Gets or sets the 'always pan parallel views' value.

If the view is not looking straight at the construction plane, then sets parallel viewports so they will not rotate.

Public propertyStatic memberDefinedViewSetCPlane
Gets or sets the 'named views set CPlane' value.

When true, restoring a named view causes the construction plane saved with that view to also restore.

Public propertyStatic memberDefinedViewSetProjection
Gets or sets the 'named views set projection' value.

When true, restoring a named view causes the viewport projection saved with the view to also restore.

Public propertyStatic memberLinkedViewports
Gets or sets the 'linked views' activated setting.

true enables real-time view synchronization. When a standard view is manipulated, the camera lens length of all parallel projection viewports are set to match the current viewport.

Public propertyStatic memberPanReverseKeyboardAction
Gets or sets if panning with the keyboard is reversed.

false, then Rhino pans the camera in the direction of the arrow key you press. true, then Rhino pans the scene instead.

Public propertyStatic memberPanScreenFraction
Gets or sets the faction used as multiplier to pan the screen.
Public propertyStatic memberRotateCircleIncrement
Gets or sets the rotation increment.

When the user rotates a view with the keyboard, Rhino rotates the view in steps. The usual step is 1/60th of a circle, which equals six degrees.

Public propertyStatic memberRotateReverseKeyboard
Gets or sets the rotation direction.

If true, then Rhino rotates the camera around the scene, otherwise, rotates the scene itself.

Public propertyStatic memberRotateToView
Gets or sets the rotation reference.

If true, then the views rotates relative to the view axes; false, than relative to the world x, y, and z axes.

Public propertyStatic memberSingleClickMaximize
Gets or sets the 'single-click maximize' value.

When true, maximizing a viewport needs a single click on the viewport title rather than a double-click.

Public propertyStatic memberViewRotation
Gets or sets the view rotation value.
Public propertyStatic memberZoomExtentsParallelViewBorder
Border amount to apply to parallel viewport during zoom extents
Public propertyStatic memberZoomExtentsPerspectiveViewBorder
Border amount to apply to perspective viewport during zoom extents
Public propertyStatic memberZoomScale
Gets or sets the step size for zooming with a wheeled mouse or the Page Up and Page Down keys.
Top
See Also