Click or drag to resize

GeneralSettingsState Properties

The GeneralSettingsState type exposes the following members.

Properties
  NameDescription
Public propertyAutoUpdateCommandHelp
Gets or sets the command help dialog auto-update feature.
Public propertyContextMenuDelay
Gets or sets the time to wait before permitting context menu display.
Public propertyEnableContextMenu
true if right mouse down + delay will pop up context menu on a mouse up if no move happens.
Public propertyMaximumPopupMenuLines
Gets or sets the maximum number of popup menu lines.
Public propertyMaximumUndoMemoryMb
Gets or sets the minimum undo memory Mb.

Undo records will be purged if there are more than MinimumUndoSteps and they use more than MaximumUndoMemoryMb.

Public propertyMiddleMouseMacro
Gets or sets the toolbar to popup when the middle mouse is clicked on a view, this value is only used when MiddleMouseMode is set to PopupToolbar.
Public propertyMiddleMouseMode
Gets or sets what happens when the user clicks the middle mouse.
Public propertyMiddleMousePopupToolbar
Gets or sets the toolbar to popup when the middle mouse is clicked on a view, this value is only used when MiddleMouseMode is set to PopupToolbar.
Public propertyMinimumUndoSteps
Gets or sets the minimum undo steps.

Undo records will be purged if there are more than MinimumUndoSteps and they use more than MaximumUndoMemoryMb.

Public propertyMouseSelectMode
Gets or sets the current selection mode.
Public propertyNewObjectIsoparmCount
Gets or sets the number of isoparm curves to show on new objects.
Top
See Also