Click or drag to resize

FileSettingsState Properties

The FileSettingsState type exposes the following members.

Properties
  NameDescription
Public propertyAutoSaveEnabled
Enables or disables Rhino's automatic file saving mechanism.
Public propertyAutoSaveInterval
How often the document will be saved when Rhino's automatic file saving mechanism is enabled.
Public propertyAutoSaveMeshes
Saves render and display meshes in autosave file.
Public propertyClipboardCopyToPreviousRhinoVersion
Gets or sets a value that decides if copies to the clipboard are performed in both the current and previous Rhino clipboard formats. This means you will double the size of what is saved in the clipboard but will be able to copy from the current to the previous version using the clipboard.
Public propertyClipboardOnExit
Gets or sets a value that determines what to do with clipboard data on exit.
Public propertyCreateBackupFiles
Gets or sets a value indicating whether to create backup files.
Public propertyFileLockingEnabled
Ensures that only one person at a time can have a file open for saving.
Public propertyFileLockingOpenWarning
Displays an information dialog which identifies computer file is open on.
Public propertySaveViewChanges
true for users who consider view changes a document change.
Public propertyTemplateFileDir
Gets or sets the directory used for template files.
Top
See Also