Click or drag to resize

FactoryBase Methods

The FactoryBase type exposes the following members.

Methods
  NameDescription
Protected methodFinalize
Finalizer
(Overrides ObjectFinalize.)
Public methodGet
Override this method to return a new instance of your class for the given ID
Public methodStatic memberRegister
Call this function during startup of current assembly to load classes with factory creation support are registed
Public methodStatic memberRegister(PlugIn)
Call this function during the startup of your plug-in to ensure that all classes that support factory creation are registed
Top
See Also