Click or drag to resize

ObjRef Methods

The ObjRef type exposes the following members.

Methods
  NameDescription
Public methodCode exampleBrep
Gets the brep if this reference geometry is one.
Public methodClippingPlaneSurface
Gets the clipping plane surface if this reference targeted one.
Public methodCode exampleCurve
Gets the curve if this reference targeted one.
Public methodCode exampleCurveParameter
If the reference geometry is a curve or edge with a selection point, then this gets the parameter of the selection point.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Public methodEdge
Gets the edge if this reference geometry is one.
Public methodFace
If the referenced geometry is a brep face, a brep with one face, or a surface, this returns the brep face.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGeometry
Gets the geometry linked to the object targeted by this reference.
Public methodHatch
Gets the hatch if the referenced geometry is one.
Public methodInstanceDefinitionPart
If sub-object selection is enabled and a piece of an instance reference is selected, this will return the selected piece.
Public methodLight
Gets the light if the referenced geometry is one.
Public methodMesh
Gets the mesh if the referenced geometry is one.
Public methodCode exampleObject
Returns the referenced Rhino object.
Public methodPoint
Gets the point if the referenced geometry is one.
Public methodPointCloud
Gets the point cloud if the referenced geometry is one.
Public methodSelectionMethod
Gets the method used to select this object.
Public methodCode exampleSelectionPoint
If the object was selected by picking a point on it, then SelectionPoint() returns the point where the selection occurred, otherwise it returns Point3d.Unset.
Public methodSelectionView
If the object was interactively selected in a particular viewport, then SelectionView() returns the view where the object was selected.
Public methodSelectionViewDetailSerialNumber
If the object was interactively selected in a page space detail view, then SelectionViewDetailSerialNumber() returns the CRhinoObject serial number of the detail view object. Use SelectionView() to get the page view that contains the detail view object. If SelectionViewDetailSerialNumber() returns 0, then the selection did not happen in a detail view.
Public methodSetSelectionComponent
When an object is selected by picking a sub-object, SetSelectionComponent may be used to identify the sub-object.
Public methodSubD
Gets the SubD if the referenced geometry is one.
Public methodSubDFace
Gets the SubDFace if the referenced geometry is one.
Public methodCode exampleSurface
Gets the surface if the referenced geometry is one.
Public methodSurfaceParameter
If the reference geometry is a surface, brep with one face, or surface edge with a selection point, then this gets the surface parameters of the selection point.
Public methodTextDot
Gets the text dot if the referenced geometry is one.
Public methodTextEntity
Gets the text entity if the referenced geometry is one.
Public methodTrim
If the referenced geometry is an edge of a surface, this returns the associated brep trim.
Top
See Also