Click or drag to resize

SelCommand Methods

The SelCommand type exposes the following members.

Methods
  NameDescription
Protected methodReplayHistory
Repeats an operation of a command.

In order to make this function work, you will likely need to grab the Result property that gives the list of input objects. Then, you will be able to replace these inputs by using one of the UpdateToX() methods of the ReplayHistoryResult.

You should NOT use any document AddX() or ReplaceX() functions, as they will break history.
Protected methodRunCommand (Overrides CommandRunCommand(RhinoDoc, RunMode).)
Protected methodSelFilter
Override this abstract function and return true if object should be selected.
Protected methodSelSubObjectFilter
To select subobjects, override this virtual function, add component indices of the subobjects that should get selected to indicesToSelect list and return true. This is called only if the SelFilter returns false and the whole object does not get selected.
Top
See Also