Click or drag to resize

MaelstromSpaceMorph Constructor

Constructs a maelstrom space morph.

Namespace:  Rhino.Geometry.Morphs
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.9
Syntax
public MaelstromSpaceMorph(
	Plane plane,
	double radius0,
	double radius1,
	double angle
)

Parameters

plane
Type: Rhino.GeometryPlane
Plane on which the base circle will lie. Origin of the plane will be the center point of the circle.
radius0
Type: SystemDouble
First radius.
radius1
Type: SystemDouble
Second radius.
angle
Type: SystemDouble
Coil angle in radians.
Remarks

If radius0 = radius1 > 0, then the morph is a rotation where the angle of rotation is proportional to the radius. If radius0 < radius1, then everything inside of the circle of radius radius0 if fixed, the rotation angle increases smoothly from 0 at radius0 to m_a at radius1, and everything outside of the circle of radius radius1 is rotated by angle. If radius0 > radius1, then everything outside of the circle of radius radius0 if fixed, the rotation angle increases smoothly from 0 at radius0 to m_a at radius1, and everything inside of the circle of radius radius1 is rotated by angle.

See Also