Click or drag to resize

ViewportInfoGetDollyCameraVector Method (Point, Point, Double)

Gets a world coordinate dolly vector that can be passed to DollyCamera().

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Vector3d GetDollyCameraVector(
	Point screen0,
	Point screen1,
	double projectionPlaneDistance
)

Parameters

screen0
Type: System.DrawingPoint
Start point.
screen1
Type: System.DrawingPoint
End point.
projectionPlaneDistance
Type: SystemDouble
Distance of projection plane from camera. When in doubt, use 0.5*(frus_near+frus_far).

Return Value

Type: Vector3d
The world coordinate dolly vector.
See Also