Click or drag to resize

ViewportInfoDollyExtents Method (IEnumerableGeometryBase, Double)

Dolly the camera location and so that the view frustum contains all of the document objects that can be seen in view. If the projection is perspective, the camera angle is not changed.

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.6
Syntax
public bool DollyExtents(
	IEnumerable<GeometryBase> geometry,
	double border
)

Parameters

geometry
Type: System.Collections.GenericIEnumerableGeometryBase

[Missing <param name="geometry"/> documentation for "M:Rhino.DocObjects.ViewportInfo.DollyExtents(System.Collections.Generic.IEnumerable{Rhino.Geometry.GeometryBase},System.Double)"]

border
Type: SystemDouble
If border > 1.0, then the frustum in enlarged by this factor to provide a border around the view. 1.1 works well for parallel projections; 0.0 is suggested for perspective projections.

Return Value

Type: Boolean
True if successful.
See Also