GripObjectGetGripDirections Method |
Sometimes grips have directions. These directions
can have any length and do not have to be orthogonal.
Namespace:
Rhino.DocObjects
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax public bool GetGripDirections(
out Vector3d u,
out Vector3d v,
out Vector3d normal
)
Public Function GetGripDirections (
<OutAttribute> ByRef u As Vector3d,
<OutAttribute> ByRef v As Vector3d,
<OutAttribute> ByRef normal As Vector3d
) As Boolean
Parameters
- u
- Type: Rhino.GeometryVector3d
u direction - v
- Type: Rhino.GeometryVector3d
v direction - normal
- Type: Rhino.GeometryVector3d
normal direction
Return Value
Type:
BooleanTrue if the grip has directions.
See Also