RhinoViewportMagnify Method (Double, Boolean, Point) |
Zooms or dollies in order to scale the viewport projection of observed objects.
Namespace:
Rhino.Display
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Magnify(
double magnificationFactor,
bool mode,
Point fixedScreenPoint
)
Public Function Magnify (
magnificationFactor As Double,
mode As Boolean,
fixedScreenPoint As Point
) As Boolean
Parameters
- magnificationFactor
- Type: SystemDouble
The scale factor. - mode
- Type: SystemBoolean
false = perform a "dolly" magnification by moving the camera towards/away from
the target so that the amount of the screen subtended by an object changes.
true = perform a "zoom" magnification by adjusting the "lens" angle
- fixedScreenPoint
- Type: System.DrawingPoint
A point in the screen that should remain fixed.
Return Value
Type:
Booleantrue if operation succeeded; otherwise false.
See Also