Click or drag to resize

ArchivableDictionaryGetVector3d Method (String, Vector3d)

Get value as Vector3d, will return defaultValue unless value was created using Set(string key, Vector3d value)

Namespace:  Rhino.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Vector3d GetVector3d(
	string key,
	Vector3d defaultValue
)

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Rhino.Collections.ArchivableDictionary.GetVector3d(System.String,Rhino.Geometry.Vector3d)"]

defaultValue
Type: Rhino.GeometryVector3d

[Missing <param name="defaultValue"/> documentation for "M:Rhino.Collections.ArchivableDictionary.GetVector3d(System.String,Rhino.Geometry.Vector3d)"]

Return Value

Type: Vector3d

[Missing <returns> documentation for "M:Rhino.Collections.ArchivableDictionary.GetVector3d(System.String,Rhino.Geometry.Vector3d)"]

See Also