Click or drag to resize

ArchivableDictionaryGetEnumValueT Method

Get an enum value

Namespace:  Rhino.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.4
Syntax
public T GetEnumValue<T>()
where T : struct, new(), IConvertible

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Rhino.Collections.ArchivableDictionary.GetEnumValue``1"]

Return Value

Type: T

[Missing <returns> documentation for "M:Rhino.Collections.ArchivableDictionary.GetEnumValue``1"]

Exceptions
ExceptionCondition
KeyNotFoundExceptionThrown when the key is not found in the dictionary.
FormatExceptionThrown when the string retrieved from the dictionary is not convertible to the enum type.
See Also