Click or drag to resize

ArchivableDictionaryGetBool Method (String, Boolean)

Get value as Boolean, will return defaultValue unless value was created using Set(string key, Boolean value)

Namespace:  Rhino.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool GetBool(
	string key,
	bool defaultValue
)

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Rhino.Collections.ArchivableDictionary.GetBool(System.String,System.Boolean)"]

defaultValue
Type: SystemBoolean

[Missing <param name="defaultValue"/> documentation for "M:Rhino.Collections.ArchivableDictionary.GetBool(System.String,System.Boolean)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Rhino.Collections.ArchivableDictionary.GetBool(System.String,System.Boolean)"]

See Also