Click or drag to resize

RhinoMath Fields

The RhinoMath type exposes the following members.

Fields
  NameDescription
Public fieldStatic memberDefaultAngleTolerance
Represents the default angle tolerance, used when no other values are provided.

This is one degree, expressed in radians.

Public fieldStatic memberDefaultDistanceToleranceMillimeters
Get Rhino's default distance tolerance in millimeters.
Public fieldStatic memberEpsilon
Gets the value of DBL_EPSILON, which is the smallest positive floating point number x such that 1 + x != 1. This is different than Double.Epsilon which is the smallest positive Double value that is greater than zero.
Public fieldStatic memberHalfPI
Quarter of a rotation. 90 degrees. 1.57...
Public fieldStatic memberQuarterPI
One eigth of a rotation. 45 degrees. 0.78...
Public fieldStatic memberSqrtEpsilon
Represents a default value that is used when comparing square roots.

This value is several orders of magnitude larger than ZeroTolerance.

Public fieldStatic memberTau
Ratio of circumference divided by radius. Full rotation. 360 degrees. 6.28...
Public fieldStatic memberTwoPI
Full rotation. 360 degrees. 6.28...
Public fieldStatic memberUnsetIntIndex
When signed int values are used in a context where 0 and small negative values are valid indices and there needs to be a value that indicates the index is not set.
Public fieldStatic memberUnsetSingle
Gets the single precision floating point number that is considered 'unset' in Rhino.
Public fieldStatic memberUnsetValue
Gets the Rhino standard Unset value. Use this value rather than Double.NaN when a bogus floating point value is required.
Public fieldStatic memberZeroTolerance
Gets Rhino's Zero Tolerance constant, which is 2^-32. In cases when an absolute "zero" tolerance is required to compare model space coordinates, ZeroTolerance is used. The value of ZeroTolerance should be no smaller than Epsilon and should be several orders of magnitude smaller than SqrtEpsilon.
Top
See Also